]> git.neil.brown.name Git - wiggle.git/blob - wiggle.spec
Add heuristic to take shortcut when too slow.
[wiggle.git] / wiggle.spec
1 Summary: A tool for applying patches with conflicts
2 Name: wiggle
3 Version: 1.2
4 Release: 1
5 License: GPL
6 Group: Development/Tools 
7 URL: http://neil.brown.name/wiggle/
8 Source0: http://neil.brown.name/wiggle/%{name}-%{version}.tar.gz
9 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
10
11 %description
12 Wiggle is a program for applying patches that 'patch' cannot
13 apply due to conflicting changes in the original.
14
15 Wiggle will always apply all changes in the patch to the original.
16 If it cannot find a way to cleanly apply a patch, it inserts it
17 in the original in a manner similar to 'merge', and report an
18 unresolvable conflict.
19
20 %prep
21 %setup -q
22
23 %build
24 make BINDIR=/usr/bin \
25      MANDIR=%{_mandir} MAN1DIR=%{_mandir}/man1 MAN5DIR=%{_mandir}/man5 \
26      CFLAGS="$RPM_OPT_FLAGS" \
27      wiggle
28
29 %install
30 rm -rf $RPM_BUILD_ROOT
31 mkdir -p $RPM_BUILD_ROOT/usr/bin
32 mkdir -p $RPM_BUILD_ROOT%{_mandir}/man{1,5}
33
34 make BINDIR=$RPM_BUILD_ROOT/usr/bin \
35      MANDIR=$RPM_BUILD_ROOT%{_mandir} \
36      MAN1DIR=$RPM_BUILD_ROOT%{_mandir}/man1 \
37      MAN5DIR=$RPM_BUILD_ROOT%{_mandir}/man5 \
38      install
39
40 %clean
41 rm -rf $RPM_BUILD_ROOT
42
43 %files
44 %defattr(-,root,root,-)
45 /usr/bin/wiggle
46 %{_mandir}/man1/wiggle.1*
47 %doc ANNOUNCE TODO notes
48 %doc p p.help
49
50
51 %changelog
52 * Thu May 22 2003 Horst von Brand <vonbrand@inf.utfsm.cl> 0.6-1 
53 - Initial build.
54
55